Anan-7000DLE MKII Problem writing firmeware

FIRMWARE TOPICS ONLY--non-firmware topics will be MOVED
Forum rules
Until such time as the New Protocol firmware goes into general release, all discussion will be concentrated here.
User avatar
nir_4x1fk
Posts: 31
Joined: Tue Jan 17, 2023 1:33 pm

Anan-7000DLE MKII Problem writing firmeware

Postby nir_4x1fk » Wed Mar 20, 2024 9:49 pm

Hello,
I tried unsuccessfully upgrading to- Metis_Orion_MkII_Protocol_2_v2.2.2.rbf.
Thetis not communicate.
After unsuccessful, I tried to return to: Metis_Orion_MkII_Protocol_2_v2.1.18.rbf.
running HPSDRBootloader 2.0.
(I also installed npcap-1.79)
Burning go OK. I switch back the firmware switch to OFF after turned the Anan OFF and ON again.
running Thetis-v2.10.3.5-u2.x64.
The software not communicate with the radio......

any Idea?
Thank you
Nir 4X1FK
User avatar
w-u-2-o
Posts: 5572
Joined: Fri Mar 10, 2017 1:47 pm

Re: Anan-7000DLE MKII Problem writing firmeware

Postby w-u-2-o » Wed Mar 20, 2024 10:14 pm

nir_4x1fk wrote:I switch back the firmware switch to OFF after turned the Anan OFF and ON again.

That's the wrong sequence. Power cycle AFTER any movement of the bootloader switch.

Precise directions can be found here: viewtopic.php?f=18&t=2333
User avatar
nir_4x1fk
Posts: 31
Joined: Tue Jan 17, 2023 1:33 pm

Re: Anan-7000DLE MKII Problem writing firmeware

Postby nir_4x1fk » Thu Mar 21, 2024 7:04 am

Hello,

I did the Power cycle.
Download Boot loader
download the firmware that I mention.
Power OFF the anan
Swith the firmware button to ON
running Boot loader
Discover the radio on the lane
loading the Firmware
writing the firmware
get successfully
Power OFF the anan
Swith the Firmware button on the anan to OFF
Power ON the ANAN
Loading Thetis
Thetis not recognize the radio....

P.s.
After having problem with firmware update in Window 11
I did success in the last time with Win10
At this time I also tried Win 10...

I hope I did all OK

Thnak you
Nir
User avatar
w-u-2-o
Posts: 5572
Joined: Fri Mar 10, 2017 1:47 pm

Re: Anan-7000DLE MKII Problem writing firmeware

Postby w-u-2-o » Thu Mar 21, 2024 10:17 am

It is possible that an Ethernet cable has partially failed somewhere, perhaps when moving the ANAN around. If a cable has failed in a way that allows 100mbit/s but not GigE to run then bootloader will be fine but Thetis will not. This was never a problem with P1, but with P2 running at GigE speed it has happened to more than one person. Make sure that your PC and/or any switches or routers are reporting GigE connections and/or swap cables.

It is possible the bootloader switch has failed in a way that is keeping it in bootloader mode. You can test this by having the switch in the normal position, power cycling the ANAN, then try contacting it with bootloader. If bootloader connects then you know the switch is probably the problem.

One other thing to consider is to reprogram the IP address of the ANAN. Remember that 0.0.0.0 is DHCP, any other address is static.
User avatar
nir_4x1fk
Posts: 31
Joined: Tue Jan 17, 2023 1:33 pm

Re: Anan-7000DLE MKII Problem writing firmeware

Postby nir_4x1fk » Thu Mar 21, 2024 8:07 pm

Hi,

Problem solved.
I always trying to burn The wrong firmware...
I looked at your Post (I did it long time ago and forgot.... :( )
My radio marked as MKii, But the serial Number is match for the MKIII
Hardware using the EP4CE115F29C8N
I download the correct firmware and it solved the problem.

Thank you for your help (As you do allays).

Nir
4X1FK

Return to “Protocol 2 Firmware (all radios)”