Thetis starting with standard frequency

vk1hx
Posts: 184
Joined: Fri Sep 13, 2019 12:03 pm
Location: Australia

Re: Thetis starting with standard frequency

Postby vk1hx » Tue Sep 26, 2023 2:59 am

Joe wrote:I just wanted to mention something else, why would you even need the option for the tx profile update on exit? The other checkbox makes more sense, it updates on change which is what you will do first anyway before you exit? Anyway that is confusing unless I’m missing something, maybe just get rid of the checkbox?

73’s
Joe
WD5Y


I guess it's there just incase you forgot to save the changes and closed Thetis, potentially loosing your efforts? :)

But yes, it would be easier if the Save TX on profile change was simply just set to save profiles changes as you make them on the fly.
73, Phil - VK1HX
Joe
Posts: 190
Joined: Tue Aug 22, 2017 5:58 pm

Re: Thetis starting with standard frequency

Postby Joe » Tue Sep 26, 2023 1:00 pm

Yes, maybe I misunderstood but I thought that’s what the save on change actually did. Never really tried just that one checkbox. It just seems redundant.

Thanks,
Joe
WD5Y
User avatar
DH1KLM
Posts: 196
Joined: Fri Dec 29, 2017 10:36 pm
Location: Germany

Re: Thetis starting with standard frequency

Postby DH1KLM » Wed Sep 27, 2023 7:40 am

Richie made a new video about this. At least when it comes to saving profiles.

https://youtu.be/ReKDw5fWLh8?si=vUjSPkOzAC_qTMtw
73 de Sigi / DH1KLM
User avatar
ramdor
Posts: 1468
Joined: Wed Jul 03, 2019 3:07 pm
Contact:

Re: Thetis starting with standard frequency

Postby ramdor » Wed Sep 27, 2023 1:09 pm

Hey all,

I have read through this thread and tried to replicate the issue regarding last used frequency etc when restarting Thetis or moving to a new band(stack) and then back again.

I am unable to replicate it at all, and have checked the code related to it but have not seen anything obvious. It could be a remnant of a database import, however my main concern is that you are seeing this problem return even after you have completely removed the database and let Thetis rebuild it. Those that are still seeing this, please could you email me (email on qrz), or attach to the github issue https://github.com/ramdor/Thetis/issues/144 , your database.xml and ErrorLog.txt files from inside folder C:\Users\<user>\AppData\Roaming\OpenHPSDR\Thetis-x64 . Do no use export to save your database but send me the database.xml that Thetis uses when you see this issue.

Thanks.
w3ub
Posts: 94
Joined: Fri Dec 14, 2018 6:32 pm
Location: Lunenburg, NS/Florida

Re: Thetis starting with standard frequency

Postby w3ub » Wed Sep 27, 2023 7:21 pm

This was also happening to me ... if I check the Auto Save TX Profile on Thetis close it happens, if I uncheck it, it does not. I can make it come and go using this check box.

I emailed you the files from the case where it is wrong.

Thanks, and welcome back.
Doug
Joe
Posts: 190
Joined: Tue Aug 22, 2017 5:58 pm

Re: Thetis starting with standard frequency

Postby Joe » Wed Sep 27, 2023 8:23 pm

Hello Ritchie,
I downloaded your latest last night. I wanted to mention that the earlier versions failed as mentioned here but your latest works without this glitch. Honestly I thought you had purposely fixed the problem but was just waiting to post it. The way I confirmed is, I run the debug (64) in visual studio, when the tx- auto save at exit is checked I get two “object not set to an instances errors and the frequency after exit and startup is glitch, this debug error pops up when I close Thetis in debug. If I uncheck the box no debug error at close and all ok. Saying all this, your latest version with changes works great no debug errors and saves frequency, etc. great too. I just got in from having a third eye surgery here so just saw this post, going to hit the recliner here, take care good to see your post. Thanks so much!

73’s
Joe
WD5Y
Joe
Posts: 190
Joined: Tue Aug 22, 2017 5:58 pm

Re: Thetis starting with standard frequency

Postby Joe » Wed Sep 27, 2023 8:46 pm

Something just became clear on this error from the earlier versions, this debug error came up at Thetis exit which makes sense this is when the tx - save on EXIT doesn’t happen, possibly a complete proper exit didn’t take place.

73’s
Joe
WD5Y
DG8DP
Posts: 16
Joined: Fri Jan 01, 2021 6:01 pm
Location: JN58WF
Contact:

Re: Thetis starting with standard frequency

Postby DG8DP » Sat Oct 07, 2023 11:47 am

The latest Version fixed the problem for me :D
Vy 73 de DG8DP
Chris

www.dg8dp.de

Return to “Thetis”